lubuntu 17.10 Artful Aardvark released

Home / lubuntu / lubuntu 17.10 Artful Aardvark released

lubuntu 17.10 has been released!

The 17.10 version has been respun. Some laptops were not suitable for the first version 17.10. The BIOS got corrupted due to Intel SPI bug in kernel. Read more on Phoronix and check if your machine could be affected in the bug issue.

What is Lubuntu?

Lubuntu is an Ubuntu flavor using LXDE. The project’s goal is to provide a lightweight yet functional distribution. Lubuntu specifically targets older machines with lower resources, but also runs great on newer hardware. Along with a simple but usable graphical user interface, Lubuntu comes with a wide variety of applications chosen for their small footprint so you can browse, email, chat, play, and be productive.

Where can I download it?

On the server with the following architectures:

Download lubuntu amd64 (64-bit suitable for most computers)

Download lubuntu i386 (32-bit most PCs before 2007)

The release notes are here if you wish to read them. We have left out some notes that are common to all flavors, so read the Ubuntu release notes if you wish.

What’s improved since 17.04?

  • We now ship with Linux Kernel 4.13.
  • General bug fix release as we prepare to switch to LXQt.
  • LXDE components have been updated with bug fixes.
  • The artwork has received an update.
  • The latest release of Audacious, 3.9, is included by default.
  • Hardinfo has been updated to the latest upstream snapshot.

System Requirements

Lubuntu is a good operating system for many old computers, but not for all of them. Some computers have too little horsepower or memory. A rule of thumb is that the computer should not be more than 10 years old (although some older computers are known to work as well).

  • Memory (RAM): for advanced internet services like Google+, YouTube, Google Drive, and Facebook, your computer needs at least 1 GB of RAM. For local programs like LibreOffice and simple browsing habits, your computer needs at least 512 MB of RAM.
  • Processor (CPU): the minimum specification for CPU is Pentium 4 or Pentium M or AMD K8. Older processors are too slow and the AMD K7 has problems with Flash video.

How do I get support?

Please check out the ubuntoforums.org.

Known Issues

For known issues, please see the release notes.

Links

%d bloggers like this: